import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "#include.+(?:<|\\\")(.+)(?:>|\\\")(?![^*\\/]*(?:\\*+(?!\\/)[^*\\/]*|\\/+(?!\\*)[^*\\/]*)*\\*\\/)";
final String string = "an ad\n"
+ "nn/* k\n"
+ "as fgj*\\ vc\n\n"
+ "*/\n\n"
+ "#include <stuffh>\n"
+ "#include \"stuff.h\"\n"
+ "#include /*\"stufuf\"*/ \"stuff.h\"\n\n"
+ "#include /*\"stufuf\"*/ <stuff.h>\n"
+ "#include <stuff.h> //sufff\n"
+ "#include \"stuff.h\" //stufffd\n"
+ "/* dsfas;dlf */\n\n\n"
+ "/* \n"
+ "#include <stuff.h>\n"
+ "#include \"stuff.h\"\n"
+ "#include \"stuff.h\"\n"
+ "#include <stuff.h>\n"
+ "#include <stuff.h> //sufff\n"
+ "#include \"stuff.h\" //stufffd\n\n"
+ "(#include.+<(.+)>|#include.+\"(.+)\")\n"
+ "*/\n"
+ "#include \"stuff\"\n"
+ "#include <stuffh>\n"
+ "#include \"stuff.h\"\n"
+ "#include /*\"stufuf\"*/ \"stuff.h\"\n\n"
+ "#include /*\"stufuf\"*/ <stuff.h>\n"
+ "#include <stuff.h> //sufff\n"
+ "#include \"stuff.h\" //stufffd\n"
+ "#ifndef \"HEad\"\n"
+ "#include/*\n"
+ "gfd\n"
+ "*/ \"stuff\"\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}