import Foundation
let pattern = ##"#include.+(?:<|\")(.+)(?:>|\")(?![^*\/]*(?:\*+(?!\/)[^*\/]*|\/+(?!\*)[^*\/]*)*\*\/)"##
let regex = try! NSRegularExpression(pattern: pattern, options: .dotMatchesLineSeparators)
let testString = ##"""
an ad
nn/* k
as fgj*\ vc
*/
#include <stuffh>
#include "stuff.h"
#include /*"stufuf"*/ "stuff.h"
#include /*"stufuf"*/ <stuff.h>
#include <stuff.h> //sufff
#include "stuff.h" //stufffd
/* dsfas;dlf */
/*
#include <stuff.h>
#include "stuff.h"
#include "stuff.h"
#include <stuff.h>
#include <stuff.h> //sufff
#include "stuff.h" //stufffd
(#include.+<(.+)>|#include.+"(.+)")
*/
#include "stuff"
#include <stuffh>
#include "stuff.h"
#include /*"stufuf"*/ "stuff.h"
#include /*"stufuf"*/ <stuff.h>
#include <stuff.h> //sufff
#include "stuff.h" //stufffd
#ifndef "HEad"
#include/*
gfd
*/ "stuff"
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)