use strict;
my $str = 'an ad
nn/* k
as fgj*\\ vc
*/
#include <stuffh>
#include "stuff.h"
#include /*"stufuf"*/ "stuff.h"
#include /*"stufuf"*/ <stuff.h>
#include <stuff.h> //sufff
#include "stuff.h" //stufffd
/* dsfas;dlf */
/*
#include <stuff.h>
#include "stuff.h"
#include "stuff.h"
#include <stuff.h>
#include <stuff.h> //sufff
#include "stuff.h" //stufffd
(#include.+<(.+)>|#include.+"(.+)")
*/
#include "stuff"
#include <stuffh>
#include "stuff.h"
#include /*"stufuf"*/ "stuff.h"
#include /*"stufuf"*/ <stuff.h>
#include <stuff.h> //sufff
#include "stuff.h" //stufffd
#ifndef "HEad"
#include/*
gfd
*/ "stuff"
';
my $regex = qr/#include.+(?:<|\")(.+)(?:>|\")(?![^*\/]*(?:\*+(?!\/)[^*\/]*|\/+(?!\*)[^*\/]*)*\*\/)/sp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}