const regex = /#include.+(?:<|\")(.+)(?:>|\")(?![^*\/]*(?:\*+(?!\/)[^*\/]*|\/+(?!\*)[^*\/]*)*\*\/)/gs;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('#include.+(?:<|\\")(.+)(?:>|\\")(?![^*\\\/]*(?:\\*+(?!\\\/)[^*\\\/]*|\\\/+(?!\\*)[^*\\\/]*)*\\*\\\/)', 'gs')
const str = `an ad
nn/* k
as fgj*\\ vc
*/
#include <stuffh>
#include "stuff.h"
#include /*"stufuf"*/ "stuff.h"
#include /*"stufuf"*/ <stuff.h>
#include <stuff.h> //sufff
#include "stuff.h" //stufffd
/* dsfas;dlf */
/*
#include <stuff.h>
#include "stuff.h"
#include "stuff.h"
#include <stuff.h>
#include <stuff.h> //sufff
#include "stuff.h" //stufffd
(#include.+<(.+)>|#include.+"(.+)")
*/
#include "stuff"
#include <stuffh>
#include "stuff.h"
#include /*"stufuf"*/ "stuff.h"
#include /*"stufuf"*/ <stuff.h>
#include <stuff.h> //sufff
#include "stuff.h" //stufffd
#ifndef "HEad"
#include/*
gfd
*/ "stuff"
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}