re = /#include.+(?:<|\")(.+)(?:>|\")(?![^*\/]*(?:\*+(?!\/)[^*\/]*|\/+(?!\*)[^*\/]*)*\*\/)/
str = 'an ad
nn/* k
as fgj*\\ vc
*/
#include <stuffh>
#include "stuff.h"
#include /*"stufuf"*/ "stuff.h"
#include /*"stufuf"*/ <stuff.h>
#include <stuff.h> //sufff
#include "stuff.h" //stufffd
/* dsfas;dlf */
/*
#include <stuff.h>
#include "stuff.h"
#include "stuff.h"
#include <stuff.h>
#include <stuff.h> //sufff
#include "stuff.h" //stufffd
(#include.+<(.+)>|#include.+"(.+)")
*/
#include "stuff"
#include <stuffh>
#include "stuff.h"
#include /*"stufuf"*/ "stuff.h"
#include /*"stufuf"*/ <stuff.h>
#include <stuff.h> //sufff
#include "stuff.h" //stufffd
#ifndef "HEad"
#include/*
gfd
*/ "stuff"
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end