using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"_(A[PM]|EM)-";
string input = @"t_name = [
""XXX_Guangzhou_AP-CN-BEI-7517"",""XXX_Jakarta_AP-ID-JAK-0001"",""XXX_TaiPei_AP-TW-TPE-0002"",
""XXX_Dubai_EM-AE-DUB-1012"",""XXX_Viladecans_EM-ES-VIL-1002"",""XXX_Ringsted_EM-DK-RIN-0001"",
""XXX_Bogota_AM-CO-BOG-1033"",""XXX_Hamburg_EM-DE-HAM-1004"", ""XXX_Bangkok_TH127"",""XXX_Bangkok_TH124";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}