// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)_(A[PM]|EM)-").unwrap();
let string = "t_name = [
\"XXX_Guangzhou_AP-CN-BEI-7517\",\"XXX_Jakarta_AP-ID-JAK-0001\",\"XXX_TaiPei_AP-TW-TPE-0002\",
\"XXX_Dubai_EM-AE-DUB-1012\",\"XXX_Viladecans_EM-ES-VIL-1002\",\"XXX_Ringsted_EM-DK-RIN-0001\",
\"XXX_Bogota_AM-CO-BOG-1033\",\"XXX_Hamburg_EM-DE-HAM-1004\", \"XXX_Bangkok_TH127\",\"XXX_Bangkok_TH124";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}