use strict;
my $str = 't_name = [
"XXX_Guangzhou_AP-CN-BEI-7517","XXX_Jakarta_AP-ID-JAK-0001","XXX_TaiPei_AP-TW-TPE-0002",
"XXX_Dubai_EM-AE-DUB-1012","XXX_Viladecans_EM-ES-VIL-1002","XXX_Ringsted_EM-DK-RIN-0001",
"XXX_Bogota_AM-CO-BOG-1033","XXX_Hamburg_EM-DE-HAM-1004", "XXX_Bangkok_TH127","XXX_Bangkok_TH124';
my $regex = qr/_(A[PM]|EM)-/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}