import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "_(A[PM]|EM)-";
final String string = "t_name = [\n"
+ " \"XXX_Guangzhou_AP-CN-BEI-7517\",\"XXX_Jakarta_AP-ID-JAK-0001\",\"XXX_TaiPei_AP-TW-TPE-0002\",\n"
+ " \"XXX_Dubai_EM-AE-DUB-1012\",\"XXX_Viladecans_EM-ES-VIL-1002\",\"XXX_Ringsted_EM-DK-RIN-0001\",\n"
+ " \"XXX_Bogota_AM-CO-BOG-1033\",\"XXX_Hamburg_EM-DE-HAM-1004\", \"XXX_Bangkok_TH127\",\"XXX_Bangkok_TH124";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}