package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\bMACHINE:\s*([^<]*(?:(?:\r\n?|\n)\S+)?)`)
var str = `MACHINE: p1prog06<br>
MACHINE: p1prog06`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}