// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\bMACHINE:\s*([^<]*(?:(?:\r\n?|\n)\S+)?)").unwrap();
let string = "MACHINE: p1prog06<br>
MACHINE: p1prog06";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}