$re = '/\bMACHINE:\s*([^<]*(?:(?:\r\n?|\n)\S+)?)/m';
$str = 'MACHINE: p1prog06<br>
MACHINE: p1prog06';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);