re = /\bMACHINE:\s*([^<]*(?:(?:\r\n?|\n)\S+)?)/m
str = 'MACHINE: p1prog06<br>
MACHINE: p1prog06'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end