#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:^|(?<= ))(red|red-orange|orange|yellow|green|green-blue|blue|violet)(?:(?= )|$)"
Local $sString = "red" & @CRLF & _
"rust" & @CRLF & _
"red orange" & @CRLF & _
"red pink purple violet" & @CRLF & _
"red-orange green-blue violet" & @CRLF & _
"green sage green-blue"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")