$re = '/(?:^|(?<= ))(red|red-orange|orange|yellow|green|green-blue|blue|violet)(?:(?= )|$)/m';
$str = 'red
rust
red orange
red pink purple violet
red-orange green-blue violet
green sage green-blue';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);