import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:^|(?<= ))(red|red-orange|orange|yellow|green|green-blue|blue|violet)(?:(?= )|$)";
final String string = "red\n"
+ "rust\n"
+ "red orange\n"
+ "red pink purple violet\n"
+ "red-orange green-blue violet\n"
+ "green sage green-blue";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}