re = /(?:^|(?<= ))(red|red-orange|orange|yellow|green|green-blue|blue|violet)(?:(?= )|$)/m
str = 'red
rust
red orange
red pink purple violet
red-orange green-blue violet
green sage green-blue'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end