const regex = /(?:^|(?<= ))(red|red-orange|orange|yellow|green|green-blue|blue|violet)(?:(?= )|$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:^|(?<= ))(red|red-orange|orange|yellow|green|green-blue|blue|violet)(?:(?= )|$)', 'gm')
const str = `red
rust
red orange
red pink purple violet
red-orange green-blue violet
green sage green-blue`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}