#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\b[\w']+\b"
Local $sString = "don't want no thot's in the 'twas ta's.hi's dhsa'" & @CRLF & _
"won't" & @CRLF & _
"'hi'" & @CRLF & _
"'hello'" & @CRLF & _
"hi!" & @CRLF & _
"how are you" & @CRLF & _
"Steve's and Drew's"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")