package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b[\w']+\b`)
var str = `don't want no thot's in the 'twas ta's.hi's dhsa'
won't
'hi'
'hello'
hi!
how are you
Steve's and Drew's`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}