$re = '/\b[\w\']+\b/m';
$str = 'don\'t want no thot\'s in the \'twas ta\'s.hi\'s dhsa\'
won\'t
\'hi\'
\'hello\'
hi!
how are you
Steve\'s and Drew\'s';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);