using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b[\w']+\b";
string input = @"don't want no thot's in the 'twas ta's.hi's dhsa'
won't
'hi'
'hello'
hi!
how are you
Steve's and Drew's";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}