// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\b[\w']+\b").unwrap();
let string = "don't want no thot's in the 'twas ta's.hi's dhsa'
won't
'hi'
'hello'
hi!
how are you
Steve's and Drew's";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}