package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\%\d*[ctYymd]+)|\$\d|([^$%]+)+`)
var str = `%03c_Ball0n%02c$1%03d_Ball0n%02d$1
%03c_Ball0n%02d-hansaBallon$1
%3c_Ball0n%2t%02d
%c_foo%Y-%m-%d-bardoo
Ball0n%02dHamburg%d`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}