import Foundation
let pattern = #"(\%\d*[ctYymd]+)|\$\d|([^$%]+)+"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
%03c_Ball0n%02c$1%03d_Ball0n%02d$1
%03c_Ball0n%02d-hansaBallon$1
%3c_Ball0n%2t%02d
%c_foo%Y-%m-%d-bardoo
Ball0n%02dHamburg%d
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)