const regex = /(\%\d*[ctYymd]+)|\$\d|([^$%]+)+/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\%\\d*[ctYymd]+)|\\$\\d|([^$%]+)+', 'g')
const str = `%03c_Ball0n%02c\$1%03d_Ball0n%02d\$1
%03c_Ball0n%02d-hansaBallon\$1
%3c_Ball0n%2t%02d
%c_foo%Y-%m-%d-bardoo
Ball0n%02dHamburg%d`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}