import re
regex = re.compile(r"(\%\d*[ctYymd]+)|\$\d|([^$%]+)+")
test_str = ("%03c_Ball0n%02c$1%03d_Ball0n%02d$1\n"
"%03c_Ball0n%02d-hansaBallon$1\n"
"%3c_Ball0n%2t%02d\n"
"%c_foo%Y-%m-%d-bardoo\n"
"Ball0n%02dHamburg%d")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")