$re = '/(?:<ins class="thisisfirstscript")([\s\S]*?)(?:data-slot="4397140188"><\/ins>)/m';
$str = '<ins class="thisisfirstscript"
style="display:inline-block;width:336px;height:280px"
data-client="ABCD"
data-slot="4397140188"></ins>
<ins class="thisissecondscript"
style="display:inline-block;width:336px;height:280px"
data-client="CDEF"
data-slot="4496122889"></ins>
<ins class="thisisfirstscript"
style="display:inline-block;width:336px;height:280px"
data-client="ABCD"
data-slot="4397140188"></ins>';
$subst = "$1index.php";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;