// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)(?:<ins class="thisisfirstscript")([\s\S]*?)(?:data-slot="4397140188"><\/ins>)"#).unwrap();
let string = "<ins class=\"thisisfirstscript\"
style=\"display:inline-block;width:336px;height:280px\"
data-client=\"ABCD\"
data-slot=\"4397140188\"></ins>
<ins class=\"thisissecondscript\"
style=\"display:inline-block;width:336px;height:280px\"
data-client=\"CDEF\"
data-slot=\"4496122889\"></ins>
<ins class=\"thisisfirstscript\"
style=\"display:inline-block;width:336px;height:280px\"
data-client=\"ABCD\"
data-slot=\"4397140188\"></ins>";
let substitution = "$1index.php";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}