import Foundation
let pattern = #"(?:<ins class="thisisfirstscript")([\s\S]*?)(?:data-slot="4397140188"><\/ins>)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
<ins class="thisisfirstscript"
style="display:inline-block;width:336px;height:280px"
data-client="ABCD"
data-slot="4397140188"></ins>
<ins class="thisissecondscript"
style="display:inline-block;width:336px;height:280px"
data-client="CDEF"
data-slot="4496122889"></ins>
<ins class="thisisfirstscript"
style="display:inline-block;width:336px;height:280px"
data-client="ABCD"
data-slot="4397140188"></ins>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1index.php"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)