package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\((.*?)\)`)
var str = `Today's tracker log(F812) was posted at 1500 there will be a new log(F813) tomorrow at 0700.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}