// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\((.*?)\)").unwrap();
let string = "Today's tracker log(F812) was posted at 1500 there will be a new log(F813) tomorrow at 0700.";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}