re = /\((.*?)\)/
str = 'Today\'s tracker log(F812) was posted at 1500 there will be a new log(F813) tomorrow at 0700.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end