const regex = /\((.*?)\)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\((.*?)\\)', 'g')
const str = `Today's tracker log(F812) was posted at 1500 there will be a new log(F813) tomorrow at 0700.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}