using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\d*([ A-Z]+((SL[1-9])?[ ]?[0-9A-Z]+)?,)+";
string input = @"14 College Rd, Maidenhead, Windsor and Maidenhead SL6 6BN, UK";
RegexOptions options = RegexOptions.IgnoreCase;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}