const regex = /\d*([ A-Z]+((SL[1-9])?[ ]?[0-9A-Z]+)?,)+/i;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\d*([ A-Z]+((SL[1-9])?[ ]?[0-9A-Z]+)?,)+', 'i')
const str = `14 College Rd, Maidenhead, Windsor and Maidenhead SL6 6BN, UK`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}