$re = '/\d*([ A-Z]+((SL[1-9])?[ ]?[0-9A-Z]+)?,)+/i';
$str = '14 College Rd, Maidenhead, Windsor and Maidenhead SL6 6BN, UK';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);