// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)\d*([ A-Z]+((SL[1-9])?[ ]?[0-9A-Z]+)?,)+").unwrap();
let string = "14 College Rd, Maidenhead, Windsor and Maidenhead SL6 6BN, UK";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}