# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<=:)[A-Za-z]+/replaced/gm;t' <<< "a:b
a.in:b
asds.sdsd:b
a:b___a.sds:bc___ab:bd"