use strict;
my $str = 'a:b
a.in:b
asds.sdsd:b
a:b___a.sds:bc___ab:bd';
my $regex = qr/(?<=:)[A-Za-z]+/mp;
my $subst = 'replaced';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";