import Foundation
let pattern = #"(?<=:)[A-Za-z]+"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
a:b
a.in:b
asds.sdsd:b
a:b___a.sds:bc___ab:bd
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"replaced"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)