const regex = /(?<=:)[A-Za-z]+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=:)[A-Za-z]+', 'gm')
const str = `a:b
a.in:b
asds.sdsd:b
a:b___a.sds:bc___ab:bd`;
const subst = `replaced`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);