using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=:)[A-Za-z]+";
string substitution = @"replaced";
string input = @"a:b
a.in:b
asds.sdsd:b
a:b___a.sds:bc___ab:bd";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}