using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[0-9]{2}(\s|)[0-9]{2}(\s|)[0-9]{2}(\.[0-9]{1,4}|)(\s|)(N|S)(\s|)[0-9]{2,3}(\s|)[0-9]{2}(\s|)[0-9]{2}(\.[0-9]{1,4}|)(\s|)(W|E)";
string substitution = @"";
string input = @"CPR4 CRANE CENTRE 430045N 811622W (APRX 480 FT ESE AD)";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}