import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[0-9]{2}(\\s|)[0-9]{2}(\\s|)[0-9]{2}(\\.[0-9]{1,4}|)(\\s|)(N|S)(\\s|)[0-9]{2,3}(\\s|)[0-9]{2}(\\s|)[0-9]{2}(\\.[0-9]{1,4}|)(\\s|)(W|E)";
final String string = "CPR4 CRANE CENTRE 430045N 811622W (APRX 480 FT ESE AD)";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}