use strict;
my $str = 'CPR4 CRANE CENTRE 430045N 811622W (APRX 480 FT ESE AD)';
my $regex = qr/[0-9]{2}(\s|)[0-9]{2}(\s|)[0-9]{2}(\.[0-9]{1,4}|)(\s|)(N|S)(\s|)[0-9]{2,3}(\s|)[0-9]{2}(\s|)[0-9]{2}(\.[0-9]{1,4}|)(\s|)(W|E)/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";