const regex = /[0-9]{2}(\s|)[0-9]{2}(\s|)[0-9]{2}(\.[0-9]{1,4}|)(\s|)(N|S)(\s|)[0-9]{2,3}(\s|)[0-9]{2}(\s|)[0-9]{2}(\.[0-9]{1,4}|)(\s|)(W|E)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[0-9]{2}(\\s|)[0-9]{2}(\\s|)[0-9]{2}(\\.[0-9]{1,4}|)(\\s|)(N|S)(\\s|)[0-9]{2,3}(\\s|)[0-9]{2}(\\s|)[0-9]{2}(\\.[0-9]{1,4}|)(\\s|)(W|E)', 'gm')
const str = `CPR4 CRANE CENTRE 430045N 811622W (APRX 480 FT ESE AD)`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);