using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?P<mrn>\d{8}).*\s+(?P<lastname>\D+),(?P<firstname>\D+)\s+(?P<dob>[\d\/]{10})\s(?P<age>\w+)\s(?P<sex>\w)";
string input = @"$
61731278 10141113787
Trauma,Test IV
01/01/1880 135Y M
7/27/2015
AC10141113787\";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}