const regex = /(?P<mrn>\d{8}).*\s+(?P<lastname>\D+),(?P<firstname>\D+)\s+(?P<dob>[\d\/]{10})\s(?P<age>\w+)\s(?P<sex>\w)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?P<mrn>\\d{8}).*\\s+(?P<lastname>\\D+),(?P<firstname>\\D+)\\s+(?P<dob>[\\d\\\/]{10})\\s(?P<age>\\w+)\\s(?P<sex>\\w)', '')
const str = `\$
61731278 10141113787
Trauma,Test IV
01/01/1880 135Y M
7/27/2015
AC10141113787\\`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}