re = /(?P<mrn>\d{8}).*\s+(?P<lastname>\D+),(?P<firstname>\D+)\s+(?P<dob>[\d\/]{10})\s(?P<age>\w+)\s(?P<sex>\w)/
str = '$
61731278 10141113787
Trauma,Test IV
01/01/1880 135Y M
7/27/2015
AC10141113787\\'
# Print the match result
str.match(re) do |match|
puts match.to_s
end